CA web site - css

Dreamweaver & Flash (ahh ahhh) plus Web related Tutorials & Resources, HTML, CSS, PHP, Flash or whatever.
Post Reply
morphim
Site Admin
Posts: 609
Joined: January 5th, 2006, 2:21 pm
Location: Next Rock after the one Cow's at

CA web site - css

Post by morphim » February 6th, 2007, 2:21 pm

Hello

I want to add background colours to the layout divs inside the main container div but DW tells me something about 'inherit' and crosses out all the css properties.
What does this mean?

The colours show up in the DW design view but not in a browser preview.

Help. Thanks. Stop.
It's always a sunny day above the clouds : )

odog
Big Bird's nest fluffer
Posts: 168
Joined: January 6th, 2006, 8:58 am
Location: The Emerald Isle (Oirland)
Contact:

Post by odog » February 6th, 2007, 4:15 pm

For the forum or the actual web site?

Either way, you could just open the actual stylesheet in notepad and enter the background attributes yourself. It's been ages since I looked at DW but it should have no problem with a simple stylesheet edit???
The sooner you fall behind, the more time you have to catch up.

Paul Stones
Ernie's rubber duckie
Ernie's rubber duckie
Posts: 283
Joined: January 6th, 2006, 11:00 pm
Location: Onanism zone

Post by Paul Stones » February 6th, 2007, 8:00 pm

Tried it out here and it works as predicted.

Can you post code?

morphim
Site Admin
Posts: 609
Joined: January 5th, 2006, 2:21 pm
Location: Next Rock after the one Cow's at

Post by morphim » February 7th, 2007, 3:07 pm

OK. Here is a chunk of the css (originally supplied by the fabulous Owen with a few jester type tweeks by me :D )

Owen - This is the web site, not the forum -I've tried to change the BG of the internal containers (although in the stuff I've pasted, I've taken it out of 'cont left' again ... sorry) However, if you try (add 'background-color: ;', the changes display themselves in the design window of DW but not when you preview in the browser. The css properties of, for example 'header' are crossed out in DW and it says that the values are inherited and therfore won't work (or somethin like that)

#container {
padding: 0 0 0 0;
margin-left: auto;
margin-right: auto;
margin-top: 0px;
margin-bottom: 0px;
width: 720px;
min-height:100%;
text-align: left;
border: 1px solid #efefef;
background-color:#fbfbfb;

}

#header {
padding:0px;
margin:0px;
background-color: #efefef;
height: 150px;
width: 720px;

}

#navlist {
margin: 0px 0px 0px 5px;
padding: 0px;
width: 710px;
float:inherit;


}

#contentleft {
margin: 0px;
padding: 5px;
width: 263px;
border-right: 1px solid #efefef;
float: left;

}
It's always a sunny day above the clouds : )

Paul Stones
Ernie's rubber duckie
Ernie's rubber duckie
Posts: 283
Joined: January 6th, 2006, 11:00 pm
Location: Onanism zone

Post by Paul Stones » February 7th, 2007, 6:09 pm

I've tried using your code and adding BG colours to the divs:

Code: Select all

#container {
padding: 0 0 0 0;
margin-left: auto;
margin-right: auto;
margin-top: 0px;
margin-bottom: 0px;
width: 720px;
min-height:100%;
text-align: left;
border: 1px solid #efefef;
background-color:#fbfbfb;

}

#header {
padding:0px;
margin:0px;
background-color: #0000FF;
height: 150px;
width: 720px;

}

#navlist {
	margin: 0px 0px 0px 5px;
	padding: 0px;
	width: 710px;
	float:inherit;
	background-color: #33CCFF;

}

#contentleft {
	margin: 0px;
	padding: 5px;
	width: 263px;
	border-right: 1px solid #efefef;
	float: left;
	background-color: #33FF99;
}
Although the colours are ugly, they do seem to work! I tested in Firefox, Opera and Safari (don't do IE, sorry!).

morphim
Site Admin
Posts: 609
Joined: January 5th, 2006, 2:21 pm
Location: Next Rock after the one Cow's at

Post by morphim » February 8th, 2007, 1:44 pm

That's very odd. Something else must be affecting it??
I'll take some stuff out and put some stuff in to see if I can't suss it out.

Thanks for the help. I might be back :D
It's always a sunny day above the clouds : )

Post Reply